Helpful X70 User Feedback

From Mark, a good concise summary of the X70 and comparison to the EX1.

Hey Mark–on your empty channel, do you switch it to ‘line’ to ‘turn it off’?

You’ll find the X70 similar to the EX1 in many many aspects. For example it gives the same profile control , and the very first thing that I used to do on EX1 (reduce the detail to make it more fluid panning) can be repeated on the X70. But there are differences of course: the lens of the X70 can’t be compared to the excellent fujinon of the EX1. But the sensor of the X70 lives on a different planet. Even with a consumer lens low light is managed beautifully on X70 and the picture quality is uncomparable. The size of the X70 looks small enough for hand-holding it but it still needs a shoulder support (the X70 “looks” small but it’s not, even the weight is not that “small”. And is “front-heavy” just like the EX1. The stabilization (set to active on X70 pretty much by default) is much MUCH better on X70. The ND filters engage in a sort of “brutal” manner on X70. So you need to be careful about that. The on-camera controls on X70 are small and difficult to push and hard to find in the dark. The audio section gives an excellent DB control but you can’t mix on-camera mics with XLR (will be one or the other). Again if XLR is set with only a shotgun attached I have to report that there are “unusual” noises coming out of the empty channel. Not the end of the world but if you are shooting a music performance live then it may be a problem. Other than that the X70 is capable of replacing the EX1 in an instant.
The X70 gives both SDI and hdmi (like the EX1r). The zoom speed of the X70 is not as slow as the EX1 at the slowest setting, but is stable , unlike the EX1 that can be jerky at times.
the autofocus of the X70 is truly “state-of-the-art”, it gives the same face recognition of the EX1 but now you can lock the face that you want to follow. That alone may make many cameramen to switch!
a final note : there are no switches underneath the handle, so we can say goodbye to those idiotic controls placed right where you put your hand to handle the camera that became a nightmare on EX1 (you grab the EX1 by the handle and the color bars or something else show up… never understood that one LOL)
Finally use the X70 on AVCHD, it’s 28Mbps but the pictures are stunning (compared t the 35Mbps of the EX1). Forget the XAVC (another idiotic and useless nonsense in my opinion).

6 responses

  1. Joe, I have a problem that I just discovered. Since buying my X70, I’ve been shooting short form videos, mostly for real estate projects. This weekend, I shot a 1-hour seminar and when I went to download the footage, I discovered–to my chagrin–that blasted 2GB limit on my clip, which spit one into 9! I called up Premiere Pro and placed two of these clips on a time line and at the break, the video seems fine, but there is an audible drop in the audio between them. It recovers quickly but it’s still noticeable. What is the fix for this? There’s gotta be a way to splice them so that the audio remains intact. BTW, I’m using Premiere CC 2015 on a PC.

    Thanks in advance, Joe, as I respect your expertise a great deal! I LOVE this camera and would hate the notion that I made a bad purchase if I want to shoot long programs! Even my (“trusty old”) GH2 will shoot as long as I have battery and media! Sidebar: I’ve heard that shooting XAVC will get past this 2GB threshold, but right now, I prefer to use AVCHD, so that’s the solution I’d be looking for.

    Cheers!

    Like

      • Joe, being the resourceful guy I allegedly am, I continued to scan the web looking for answers and may have found one on Adobe’s Premiere Pro “Help” section:

        https://helpx.adobe.com/premiere-pro/using/importing-assets-tapeless-formats.html#about_spanned_clips

        I followed the instructions using Premiere’s Media Browser and it WORKED! That’s the good news. The not-as-good news is that you can’t use the Media Browser to just copy or move the combined file elsewhere on the computer’s hard drive. So far, the only solution I’ve found that I can be assured of is to import the file into Premiere, using the Media Browser, place the combined file on the timeline, and export it wherever else I want it to go. Convoluted as hell, I know, but at least it works. If you or anyone else who follows you has another idea, I’d love to hear it, but in the meantime, at least I can now work with the complete file–with no breaks in it!!

        Thanks again!

        Like

  2. Interesting. I recently acquired a PXW-X70 in order to undertake a couple of intense fast turnaround shoots and edits (very successfully) and I wondered why there was noise on the XLR mic inputs when connecting either a Rode NG-2 short rifle mic or Sony ECM-77 tieclip mic to Ch1 looped to Ch2. Last week I took delivery of a Sony ECM-MS2 Mid-Side Stereo mic which is phantom powered and uses both XLR inputs. No noise!

    I thought the reason for the noise on the Rode NG-2 and Sony ECM-77 was batteries being low but no – batteries were brand new.

    Like

  3. Joe, ch2 on line and -20db helps, but the noise is still there. At first I thought that it was because of the lavalier that I put o ch2 to have some ambient when I have a shotgun on ch1 (I use a sony CS3 for that, on ch2) so I didn’t pay attention. But then I can hear the noise even with another mic (radio, audio technica system10 that I use only with a wireless mic). to cut the story short I tried everything , even phantom on both channels like I used to do with a PMW200 :it sounds like a bug. If you stop recording the noise goes away (while still monitoring via headphones). Not a big deal after all ad it only affects the ch2, while the ch1 is fine. Talking about radio you should try the new “freedom from the greedy DTV who want to get all the channels” using a 2.4GHZ instead of UHF , like the audio technica system 10. Comes with an absurd price tag (but not as absurd as the sennheiser G3) and the mic is exactly like the sure SM58 , impressive vocal but for interviews you must be careful to keep the mic close to the mouths. It replaces the plug-on that I still have for a (splendid) omni RE50 (electro voice) that had to retire after going under trucks (literally) and similar stunts during 15 years (and more) of use. Anyway since I work in NYC Ive decided to abandon the UHF systems (I have a sennheiser g2) because the future is in the 2.4GHz systems in my opinion. The UHF became such a hit-and-miss lately, I had enough. The system10 works like this: you turn it on and .. it works… just like that. no scannning, no pairing no syncing , no nuthing: just works. Again I don’t have a lavalier on system10, just the microphone (and receiver of course). Very happy so far.

    Like

Don't just sit there...say something!

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s