Sony PXW X70

Sony-pxwx70

Under this navigation tag you will find the original articles and reviews I did on the Sony PXW X70 including plenty of sample footage.

You will also find additional useful information on the camera provided by owners of this camera who also subscribers to this blog.

15 responses

  1. HI Joe,

    please e mail me. Question about Sony turning down a historic Big Sur event photo with X 70 on the scene… Are they not an open company to being honored with their camera ?..thank you
    911eyenews@gmail.com….Cheers Joe, love the X70 ! Great call for me to buy on your part !

    Like

  2. Hi Joe – first off, Thanks SO much for the work on the PXW-X70. Trained on the NX5-U, and since I picked up the X-70, review removing any reservations I had, I haven’t looked back. Loved run’n’gun as well, and have been recommending it to colleagues.

    My question is for some reason recently, with the auto/manual switch set to Manual mode I don’t seem be able to get rid of my auto settings. I’ve done 2 shoots where I’ve had this problem and luckily the camera is good enough to get fantastic results with auto, but I didnt have this problem before.

    I’m wondering what exactly is it that I’m forgetting to / or what other setting i accidentally activated that might be causing this? I’ve literally gone through the menu and checked everything that looked like it could be remotely related….

    Any ideas on this phenom?

    Thanks!

    Charles

    Like

    • When you put it in manual, in order to set the various things (iso, iris, etc.) where you want them, you have to push the button under each of those options on the side of the camera. When you do, it appears in a little white box. You then set the setting you want and move onto the next one. BUT, if you push the button again, it will return to auto for that setting. This is useful if, say, you want to lock aperture at f2.8 and leave iso or shutter speed on auto. Or you can set all 3 to full manual. Or just two.

      Thanks for the compliment on the book. If you haven’t left a review, please do.

      Like

      • Gotcha! Great thanks so much! 🙂 Left a review on Amazon, happy to do it, really loved the book!

        Like

  3. I have the PXW-X70 and am trying to shoot AVCHD 720/60p HQ to get the 777 minutes on my 64gb memory card. I want to have the DATE and TIME displayed on playback. On the DISPLAY SET menu there is no option to select DATA CODE, it jumps from Shutter Display to LCD Bright and completely overlooks the DATA CODE option. Firmware is 2.00. I have assigned the DATA CODE to assign button 3 (in place of the picture profile) and there are no options that I can find to display that data. I had hoped a experienced person like yourself could help. I need to display the DATE AND TIME as I will be shooting some legal proceedings and this is a requirement. Any help you can pass along will be extremely helpful. Thank you.

    Like

    • Date record doesn’t seem to be an activated function yet. It’s in the menu, but grayed out. Never needed to do it myself, so never really checked into it. See if you can do anything with this comment I found on a forum asking about the same: How To Insert Date And Time To A Video File
      Options
      Just download the video files from the camcorder using the Import Media Files Tool from the Sony PMB browser. The Import tool automatically saves the files with names indicating the date-time, example: 20110611160828.m2ts (date 2011-06-11 time 16:08:28).

      Like

  4. Hi.

    1. While comparing different cameras for producing educational videos, I came across your YouTube review of the X70.

    I wish there were similar reviews for other cameras as well.

    2. The point I am trying to make is that your review was extremely helpful and realistic, in a way where I can ‘see’ if the camera meets my requirements. Now, it is in my shortlist.

    Thank you for your time and effort. It is greatly appreciated by me, who has very limited knowledge about the finer points of filming videos.

    Regards,
    Navneet Gaur.

    Like

  5. I just purchased the x70 and I had a quick question.
    On the xlr handle attachment, there seems to be a little play in the shotgun mic clamp. Is this normal?
    Thanks!

    Like

    • If it’s the ‘play’ I think you’re talking about, yes. That’s vibration dampening to help prevent direct transmission of noise through your body or tripod or whatever through the camera to the mic.

      Like

Don't just sit there...say something!

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s